加入收藏 | 设为首页 | 会员中心 | 我要投稿 云计算网_泰州站长网 (http://www.0523zz.com/)- 视觉智能、AI应用、CDN、行业物联网、智能数字人!
当前位置: 首页 > 综合聚焦 > 资源网站 > 资源 > 正文

HDOJ/HDU 1250 Hat#39;s Fibonacci(大数~斐波拉契)

发布时间:2021-03-15 23:16:03 所属栏目:资源 来源:网络整理
导读:Problem Description A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1. F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4) Your task is

Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence,with the first two members being both 1.
F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input,and print that Fibonacci number.

Input
Each line will contain an integers. Process to end of file.

Output
For each case,output the result in a line.

Sample Input
100

Sample Output
4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.

就是根据这个公式:
F(1) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)

输入一个n,输出f(n)的值。

注意,这是大数~答案的位数高达2005位~~~

再一次体会Java大数的强大吧~

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    static BigInteger f[] = new BigInteger[7045];
    public static void main(String[] args) {
        dabiao();
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n =sc.nextInt();
            System.out.println(f[n]);
            //System.out.println("---------");
            //System.out.println(f[n].toString().length());
            //开数组~看开到多少位的时候,位数大于2005
        }
    }
    private static void dabiao() {
        f[1]=new BigInteger("1");
        f[2]=new BigInteger("1");
        f[3]=new BigInteger("1");
        f[4]=new BigInteger("1");
        for(int i=5;i<f.length;i++){
            f[i]=f[i-1].add(f[i-2]).add(f[i-3]).add(f[i-4]);
        }
    }
}

(编辑:云计算网_泰州站长网)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    热点阅读